Servitimbre pone caracteres raros en las letras acentuadas

Foro de soporte para el Servidor de Timbres
ijamconsulting
Mensajes: 56
Registrado: Mar Nov 06, 2012 8:09 am

Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor ijamconsulting » Lun Dic 05, 2022 4:20 pm

Hola,

Tenemos un caso donde el archivo txt en las descripciones del producto contiene acentos para algunos xml timbrados me respeta los acentos y para otros xml timbrados que genera ServiTimbre no y coloca caracteres raros

El archivo plano txt esta con codificacion ansi (ascii como se comenta arriba).

Anexo imagen para mayor detalle.
Adjuntos
Error_Descripciones.jpg
Error_Descripciones.jpg (222.51 KiB) Visto 329 veces

Avatar de Usuario
Dado
Mensajes: 15413
Registrado: Mar Jul 06, 2010 8:56 pm

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor Dado » Lun Dic 05, 2022 4:32 pm

ijamconsulting escribió:...El archivo plano txt esta con codificacion ansi (ascii como se comenta arriba)...


No lo estan, tus archivos de texto no esta en ascii plano, estan codificados en UTF-8 y la unica forma de verlo es con un editor hexadecimal, NO se puede ver la diferencia con el bloc de notas
ADDENDAS? VALIDACION? CODIGO PARA PROGRAMAR TU PROPIA SOLUCION? TODO LO TENEMOS EN WWW.VALIDACFD.COM VISITANOS !!

ijamconsulting
Mensajes: 56
Registrado: Mar Nov 06, 2012 8:09 am

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor ijamconsulting » Lun Dic 05, 2022 5:37 pm

Pero lo que comentas, seria correcto si todos los xml se generaran de forma incorrecta, es decir, que si el error es consistente, no deberia de haber xml con caracteres correctos.

Para contrastar este tema, te comentamos que si descagarmos el xml del SAT este se descarga con los caracteres correctos (con acentos) pero el que nos genera o devuelve servitimbre lo baja incorrectamente.

Anexo los xml para mayor evidencia.
Adjuntos
SERVITIMBRE_MS&040819FJA_I_INVR_3251_PME380607P35_2022-12-01_1065042.00_8945F8E2-D8D4-4543-8F7A-0A93208B4B6E.xml
(6.01 KiB) Descargado 21 veces
SAT_8945F8E2-D8D4-4543-8F7A-0A93208B4B6E.xml
(6.01 KiB) Descargado 25 veces

Avatar de Usuario
Dado
Mensajes: 15413
Registrado: Mar Jul 06, 2010 8:56 pm

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor Dado » Lun Dic 05, 2022 5:51 pm

Tendras el archivo TXT (o genera uno nuevo) que incluya descripccion con palabras acentudas, para darle una revisada
ADDENDAS? VALIDACION? CODIGO PARA PROGRAMAR TU PROPIA SOLUCION? TODO LO TENEMOS EN WWW.VALIDACFD.COM VISITANOS !!

ijamconsulting
Mensajes: 56
Registrado: Mar Nov 06, 2012 8:09 am

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor ijamconsulting » Lun Dic 05, 2022 6:16 pm

Claro.
Te anexo el archivo.
Adjuntos
FACMS&040819FJA_40_3251.txt
(1.92 KiB) Descargado 21 veces

ijamconsulting
Mensajes: 56
Registrado: Mar Nov 06, 2012 8:09 am

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor ijamconsulting » Mar Dic 06, 2022 2:50 pm

Hola, Cubo:

Algún comentario, disculpa el seguimiento, pero como veras son medicamentes y los validadores de Pemex validan descripción y no pasan las facturas y esta generando problemas para la entrega de medicamento.

Quedo atento a tus comentarios.

Avatar de Usuario
Dado
Mensajes: 15413
Registrado: Mar Jul 06, 2010 8:56 pm

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor Dado » Mar Dic 06, 2022 2:53 pm

Hicimos pruebas y todas fueron correctas, el Servitimbre maneja bien los acentos
ADDENDAS? VALIDACION? CODIGO PARA PROGRAMAR TU PROPIA SOLUCION? TODO LO TENEMOS EN WWW.VALIDACFD.COM VISITANOS !!

ijamconsulting
Mensajes: 56
Registrado: Mar Nov 06, 2012 8:09 am

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor ijamconsulting » Mar Dic 06, 2022 2:57 pm

Alguna, idea o hipótesis porque este sucediendo que nos puedas dar al respecto?
La alternativa solución es estarlos descargando del SAT, pero pues no es el caso.

Avatar de Usuario
Dado
Mensajes: 15413
Registrado: Mar Jul 06, 2010 8:56 pm

Re: Servitimbre pone caracteres raros en las letras acentuadas

Mensajepor Dado » Mar Dic 06, 2022 3:01 pm

Que haces con el XML despues de que se timbra ?

Talvez en algun proceso posterior es cuando se pierde la codificacion UTF-8
ADDENDAS? VALIDACION? CODIGO PARA PROGRAMAR TU PROPIA SOLUCION? TODO LO TENEMOS EN WWW.VALIDACFD.COM VISITANOS !!


Volver a “SOPORTE ServiTimbre”

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 3 invitados